1. #1
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT

    No tengo audio altavoces internos en MacBook 2009 con OS X El Capitan

    Buenas noches, hacia tiempo que tenía acumulando polvo un MacBook 6,1 del 2009 blanquito, el caso que lo he puesto en marcha y no me funcionan los altavoces, y si conecto unos auriculares, tampoco se escucha nada ...

    El caso es que si conecto unos altavoces por bluetooth, se escucha todo perfectamente.

    ¿Alguien sabe porque?

    Saludos




  2. #2
    BonesMac  Nivel 2 MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac
    Avatar de BonesMac

    Hola, yo intentaría dos cosas: primero resetear la PRAM para resetar los ajustes de fabrica. Y segundo meter la clavija de 3.5 mm un par de veces y extraerla.

    A veces se queda un contacto pillado y OS X entiende que están conectados

    ¿Ves los altavoces internos disponibles en Preferencias-> Audio?




  3. #3
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    Buenos días, he probado a meter varias veces un jack de 3.5, y en preferencias - Audio se ve claramente que pasa de Altavoces internos a Auriculares y cuando lo saco vuelve a Altavoces Internos. Lo de resetear la PRAM me es imposible, porque mi teclado del macbook tiene constantemente presionada la tecla Ctrl, por lo que no puedo hacer correctamente la combinación de teclas. Se puede resetear de alguna otra manera que no sea con la combinación de teclas?




  4. #4
    Applesan@ Nivel 0 MacPoints y autoridad de milon MacPoints y autoridad de milon
    Avatar de milon

    Hola, ¿Qué versión de OS X tienes? y otra cosa, ¿has realizado alguna actualización que justifique ese cambio?

    Saludos




  5. #5
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    No, no he hecho ninguna actualización , tengo el capitán, pero en windows con Bootcamp tampoco suena, ni cuando lo enciendo el típico sonido. Ni los altavoces ni el jack funcionan, por por bluetooth si ...




  6. #6
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    Lo que entiendo es que si por bluetooth sale sonido, en Preferencias del Sistema, me aparece Altavoces internos, cuando conecto el Jack cambia a Auriculares, significa que la tarjeta de sonido funciona no?

    El altavoz podría cambiarlo, no hay problema, venden los repuestos, pero no se si volvería a funcionar, y el Jack? se activa y desactiva, por lo que podría estar estropeado?, me parece muy raro dos componentes tan diferentes, se rompan ...




  7. #7
    Applesan@ Nivel 0 MacPoints y autoridad de milon MacPoints y autoridad de milon
    Avatar de milon

    Pues con los datos que estás dando me creo que vas a tener que desmontar tu MacBook, si el mecanismo del jack detecta perfectamente cuando tienes auriculares y cuando no porque son los altavoces internos, significa que el módulo de audio está presente y funcionando.


    Además si en perfil del sistema, en Extensiones ves cargado AppleHDA.Kext igualmente es porque está presente y bien reconocido.


    Una vez me paso algo así en un Mac Mini del 2009, y al final era un cable tipo flex que salía del módulo de audio a la placa base.


    Probablemente algún cablecito se te ha soltado. Si te animas, con paciencia y haciendo fotos en cada paso tú mismo puedes desmontarlo con cuidado.


    Ah, para resetear la PRAM que es importante, puedes valerte de un teclado USB de PC de esos baratos, lo conectas y puedes restaurar porque tiene más prioridad que el teclado interno.
    Prueba esto último antes de desmontar nada




  8. #8
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    tengo un teclado USB original de Apple, el metalico con el teclado numerico a la derecha, lo he intentado con el conectado, incluso simplemente dejar presionado el ALT para que me aparezca el selector de arranque, pero parece que no da prioridad, parece que detecta siempre el Ctrl presionado, no he probado con uno de PC, al ser uno original de Apple intuyo que seria mejor.

    Lo de desmontarlo, da reparo, pero me tendré que atrever, porque esto es un coñazo. de todas formas creo que no hay flex que puedan estar dañados ya que todo va integrado en la placa (jack) y los altavoces aunque estuvieran rotos o desconectados tendria que ser indiferente al Jack no?




  9. #9
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    lo he intentado con un teclado de PC, y lo que hace es entrar en el modo Recuperación para reinstalar MacOs ...




  10. #10
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    PD: he conseguido resetear la PRAM, pero sigue exactamente igual, nada por altavoces nada por jack, y por bluetooth funciona




  11. #11
    Applesan@ Nivel 0 MacPoints y autoridad de milon MacPoints y autoridad de milon
    Avatar de milon

    Si, en cualquier caso el teclado de Apple también es mejor. Y si tiene más prioridad, fijate que presionado la tecla ALT te da la selección del target


    Mirando un poco tu MacBook, este es el cable que sale de la placa base


    attachment.php?attachmentid=11502&d=1458477033


    Y luego va a su altavoz y jack


    attachment.php?attachmentid=11503&d=1458477033


    No hay mucho más que mirar.


    Sobre el Bluetooth, es que son dos cosas distintas, está integrado en la Airport, en la wifi y lo que hace OS X desde su propio 'driver' (kext) es redireccionar el audio a ese módulo así que por eso te funciona.




  12. #12
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    ya entiendo lo del Bluetooth, gracias.

    Estoy viendo lo del cable de la placa base que se conecta el altavoz, en un principio he mirado el mio y esta bien, sigo el cable y va al altavoz que esta debajo de un Flex del Bluetooth y wifi, pero no comprendo lo del Jack, ya que el Jack estoy viendo que está muy lejos de lo que es el altavoz, y no veo ningun cable que vaya del altavoz hacia el Jack

    puede que se haya estropeado el altavoz?




  13. #13
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    He comprado un altavoz para sustituirlo, crees que esto me resolverá al menos el altavoz?, el Jacl la verdad es que no lo suelo utilizar.

    Pero no se si esto me lo resolverá...

    lo del Bluetooth me dices que se redirecciona el sonido por el kext, pero esto también me pasa con windows, en bootcamp, arranco y conecto por bluetooth y se escucha perfectamente.

    Empiezo a desesperarme :'(




  14. #14
    BonesMac  Nivel 2 MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac MacPoints y autoridad de BonesMac
    Avatar de BonesMac

    Hola, si tienes el cable conector mal o el altavoz, nunca funcionará ni en Mac ni en Windows o Linux. El BT si está perfecto, funciona igual en OS X que en Windows.

    No te preocupes que es una avería de 5 euros, no más. Y un poco de paciencia claro.




  15. #15
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    Bueno os comento, me llego el altavoz, lo he sustituido, y el sonido sigue sin funcionar, tampoco sale sonido por el jack de los auriculares ... Ni en OsX ni en Windows ...

    ¿Tiro la toalla? ¿Se me ha jodido la placa base la parte del audio?




  16. #16
    Applesan@ Beta Nivel 0 MacPoints y autoridad de Patotropical MacPoints y autoridad de Patotropical
    Avatar de Patotropical

    Hola, es muy raro lo que te pasa, si tú tienes esta pantalla

    attachment.php?attachmentid=11540&d=1459685293


    Eso significa que tu módulo de audio está bien y OS X lo ve. No puede estar rota la placa base de ninguna forma.

    Lo único que podría ser es el kext de audio que en OS X El Capitan lo han cambiado y no reconoce bien la salida de audio en tu modelo de MacBook. o lo que te han comentado antes del altavoz y cable que ya queda descartado por tí.

    Una pista, si recuerdas cuando te funcionó, por ejemplo con OS X Yosemite, yo descargaría la combo de Yose, extraería el kext y lo instalaría. Por probar....

    Saludos




  17. #17
    🍒 Nivel 1 MacPoints y autoridad de senhez MacPoints y autoridad de senhez
    Avatar de senhez

    Hola amigo eNCHANT, estoy revisando tu modelo de Macbook en la base de datos Apple y el 6.1 no es del 2009. Es el MacBook Pro (17 pulgadas, mediados de 2010)

    Para el mediados de 2009 es el 5.3. Por favor confirma este dato y te paso una actualización para tu Mac, quizás solucione el problema.

    Para conocer tu modelo de Mac en acerca de este Mac tienes la información
    yosemite-system-information-hardware-overview.jpg

    Saludos




  18. #18
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    Hola, te equivocas, lo primero es Finales del 2009 no Mediados del 2009, por lo que es la version 6,1, y es MacBook no MacBook Pro, os paso capturas de pantalla del modelo, y de las Preferencias del Sistema la opción del Audio, con los Altavoces Internos y con el Jack ... y sin escucharse nada ni en MacOs ni en Windows.



    macbook-finales-2009.jpg


    macbook-finales-2009-audio.jpg

    macbook-finales-2009-modelo-6.1.png




  19. #19
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    No creo que sea problema de ningún Kext, eso significaría que el problema es del sistema operativo MacOs, pero también pasa en bootcamp en Windows, que no tiene nada que ver con los Kext.

    No recuerdo la ultima vez que funcionó.

    Cita Patotropical dijo: Ver Mensaje
    Hola, es muy raro lo que te pasa, si tú tienes esta pantalla

    attachment.php?attachmentid=11540&d=1459685293


    Eso significa que tu módulo de audio está bien y OS X lo ve. No puede estar rota la placa base de ninguna forma.

    Lo único que podría ser es el kext de audio que en OS X El Capitan lo han cambiado y no reconoce bien la salida de audio en tu modelo de MacBook. o lo que te han comentado antes del altavoz y cable que ya queda descartado por tí.

    Una pista, si recuerdas cuando te funcionó, por ejemplo con OS X Yosemite, yo descargaría la combo de Yose, extraería el kext y lo instalaría. Por probar....

    Saludos




  20. #20
    Applesan@ Beta Nivel 0 MacPoints y autoridad de Patotropical MacPoints y autoridad de Patotropical
    Avatar de Patotropical

    No había pensado en eso de bootcamp. De todas formas si te ves muy apurado por suerte esa placa base nueva a estrenar ya es barata, sobre 200 euros con procesador y GPU, es decir, completa menos la memoria RAM


    Y funciona en los macbooks principios y mediados de 2009


    Echa un vistazo aqui


    Si no es el tuyo seguro que hay otra adecuada



    Cita eNCHANT dijo: Ver Mensaje
    No creo que sea problema de ningún Kext, eso significaría que el problema es del sistema operativo MacOs, pero también pasa en bootcamp en Windows, que no tiene nada que ver con los Kext.

    No recuerdo la ultima vez que funcionó.




  21. #21
    Tímido Nivel 0 MacPoints y autoridad de eNCHANT
    No me merece la pena gastarme 200€ en una placa base, viendo que hay MacBooks de este año por 300€, la cosa seria solucionar el problema, o aguantarme y usar una tarjeta de sonido USB y como altavoces pues como lo hago ahora, uno Bluetooth, pero es un coñazo estar con cacharros por todos los lados :(


    Cita Patotropical dijo: Ver Mensaje
    No había pensado en eso de bootcamp. De todas formas si te ves muy apurado por suerte esa placa base nueva a estrenar ya es barata, sobre 200 euros con procesador y GPU, es decir, completa menos la memoria RAM


    Y funciona en los macbooks principios y mediados de 2009


    Echa un vistazo aqui


    Si no es el tuyo seguro que hay otra adecuada




  22. #22
    Applesan@ Beta Nivel 0 MacPoints y autoridad de Patotropical MacPoints y autoridad de Patotropical
    Avatar de Patotropical

    Tengo que reconocer que tienes un problema de lo más curioso que he visto. Tus capturas de pantalla son perfectas, el dispositivo está ahí y todo lo demás.

    Diras lo que quieras, pero si eso estuviera roto no aparecería. Yo sigo pensando que es cosa de drivers, y en Windows si no funciona igual. O incluso he llegado a pensar que tiene un firmware distinto modelo

    ¿Tú has actualizado alguna vez el firmware? ¿Eres el primer propietario?


    Es que no lo veo una explicación coherente. De todas formas, más que una tarjeta USB de 20 euros yo pensaría en un altavoz BT y listo de 20 euros o así para cuando estés en casa.

    Y cuando estés en la calle, pues auriculares BT




Notas relacionadas con este artículo que te pueden interesar

  1. Macbook Muda sin audio
    Publicado por Smok1986 en MacBook Air / MacBook / MacBook Pro
    Comentarios: 5
    Último comentario: 11/12/17, 18:06:32
  2. tengo memoria externa del PC y no funciona con mi MacBook. ¿porqué?
    Publicado por laura_marcela en MacBook Air / MacBook / MacBook Pro
    Comentarios: 0
    Último comentario: 16/02/10, 19:30:55
  3. Recomendacion Macbook / Macbook Pro para audio (Logic, Ableton...)
    Publicado por mundakas en MacBook Air / MacBook / MacBook Pro
    Comentarios: 9
    Último comentario: 06/06/09, 15:10:27
  4. Comentarios: 3
    Último comentario: 01/11/07, 12:10:15
  5. Problemas de audio en MacBook
    Publicado por alandalus en MacBook Air / MacBook / MacBook Pro
    Comentarios: 3
    Último comentario: 31/08/06, 10:26:35

Otros temas destacados