Ultrasn0w también ha sido actualizado a la versión 1.2.3 para proporcionar la posibilidad de desbloqueo de iOS 4.3.3. Al igual que su predecesor, sin embargo, sólo funciona en los iPhones con basebands más antiguos, incluyendo: iPhone 4 – 1.59.00 ,Phone 3G/3GS - 4.26.08, 5.11.07, 5.12.01, 5.13.04 y 6.15.00.

Lo encuentran en cydia como siempre